当サイトで配布中のバイナリを利用する際の注意

X11 について

当サイトで配布しているバイナリの多くは X11 を必要としますが、Mountain Lion 以降のバージョンからは X11 が付属せず、代わりに X11 を起動しようとすると、XQuartz をインストールするよう誘導されます。当サイトで配布しているバイナリを利用する場合は、指示に従って XQuartz をインストールしてください。ただし、一旦インストールすると、OS を再インストールする以外に元に戻す方法がありませんので、慎重に判断してください。

Apple: X11 および OS X について

Gatekeeper について

一部のバイナリを実行しようとすると、「開発元が未確認のため開けません。」というつれないメッセージが表示され、実行できません。初回のみ以下の手順により起動すると、次回からは普通にダブルクリックで起動できるようになると思います。

  1. アイコンを右クリック(もしくは「control」キーを押しながら左クリック)。
  2. 表示されるコンテクストメニューから「開く」を選択。

上記の手順でも開くことができない場合は、以下の要領で拡張属性を削除する必要があるかもしれません。

xattr -rc /Applications/gnuplot.app
xattr -rc /Applications/Maxima.app

Apple: Gatekeeper について

最終更新日:2015/01/22
カテゴリーMac